Nur ausgewählte Werte addieren

In diesem Beitrag erfahren Sie, wie Sie ausgewählte Werte addieren.

Die folgende Tabelle zeigt bereits das Ergebnis: Nur die Werte, die mit einem X ausgewählt wurden, werden in der Zelle F5 summiert.

Das Ziel: Nur ausgewählte Zellen addieren (Bild1)

Im Bonusteil erfahren Sie, wie Sie die Zellen, deren Inhalt zur Addition ausgewählt wurden, farbig hervorheben.

Die Funktion SUMMEWENNS()

Die Lösung bietet Ihnen die Funktion SUMMEWENNS().

  • Klicken Sie in die Zelle, in der Sie die Summe bilden möchten.
  • Erfassen Sie die folgende Formel und bestätigen Sie mit [¢]:

=SUMMEWENNS(C5:C16;D5:D16;“X“)

Hinweis: Beim vergleichenden Buchstaben, in diesem Beispiel beim X, ist es egal, ob es ein Groß- oder ein Kleinbuchstabe ist.

Die Formel addiert nur, wenn der Wert durch das X ausgewählt wurde (Bild2)
  • Testen Sie Ihre Formel, indem Sie verschiedene Werte zur Addition auswählen.

Die Lösung (Bild3)

SUMMEWENNS() vs. SUMMEWENN()

Ihnen ist bestimmt aufgefallen, dass es zwei Funktionen SUMMEWENN() bzw. SUMMEWENNS() gibt. SUMMEWENNS() ist die neuere und sie kann bis zu 127 Kriterien abfragen, während SUMMEWENN() nur ein Kriterium prüft.

Für das Beispiel hätte es auch die alte Funktion SUMMEWENN() getan.

Mit der neuen Funktion SUMMEWENNS() ist die alte Funktion praktisch überflüssig geworden, so dass es ratsam ist, nur noch die neue Funktion einzusetzen.

Bonus: Die ausgewählten Werte automatisch einfärben

Jetzt möchten Sie mit Hilfe der bedingten Formatierung die Umsätze automatisch hervorheben, die zur Berechnung ausgewählt wurden.

  • Markieren Sie die Umsätze C5:C16.
  • Wählen Sie Start / Bedingte Formatierung / Neue Regel.
  • Aktivieren Sie den Eintrag Formel zur Ermittlung der zu formatierenden Zellen verwenden.
  • Klicken Sie in das Feld Werte formatieren, für die diese Formel wahr ist und geben Sie die folgende Formel ein:

=C5=“X“

Hinweis: Wenn Sie, während Sie die Formel schreiben, in die Zelle C5 klicken, setzt Excel diese Zelle als absoluten Bezug mit den $-Symbolen $C$5. Diese müssen entfernt werden. Drücken Sie dreimal die Taste [F4].

  • Klicken Sie auf die Schaltfläche Formatieren, wählen Sie auf dem Register Ausfüllen die gewünschte Farbe aus und bestätigen Sie mit OK.

Die Formel in der bedingten Formatierung  (Bild4)
  • Bestätigen Sie mit OK.
  • Testen Sie wieder Ihre Formel, indem Sie Werte zur Addition auswählen.

Die ausgewählten Zellen sind noch besser zu erkennen  (Bild5)

Comments are closed.

Kategorien

Archiv